Converting problems

Page 1 of 2 1, 2  Next

Go down

Converting problems

Post by F1CFan1804 on Mon 6 Apr - 20:04

Hello guys,

I recently started to do some conversions of rFactor tracks tot F1C for private use.
The problem I had was that when loading the track it came three-quarters of the way and the game crashed.
Does anyone of you know what the problem is?

F1CFan1804
Competition racer
Competition racer

Messages : 176
Date d'inscription : 2014-11-15
Localisation : Netherlands

Back to top Go down

Re: Converting problems

Post by JALNERVION on Wed 1 Jul - 20:15

What track have that problem?
avatar
JALNERVION
Competition racer
Competition racer

Messages : 119
Date d'inscription : 2014-11-09

Back to top Go down

Re: Converting problems

Post by F1CFan1804 on Thu 2 Jul - 11:07

It was Motegi I think, but I fixed it. The lighting values in the GDB file were incorrect, and the game couldn't process it. So I changed it to the values in your tutorial and it worked after that.

F1CFan1804
Competition racer
Competition racer

Messages : 176
Date d'inscription : 2014-11-15
Localisation : Netherlands

Back to top Go down

Re: Converting problems

Post by Lee67 on Thu 2 Jul - 12:37

Do you use the "lighting values" in GDB-file for F1C? Shocked I don't... Embarassed
avatar
Lee67
F1 Driver
F1 Driver

Messages : 539
Date d'inscription : 2014-09-21
Age : 50
Localisation : Somewhere in the Czechlands!

Back to top Go down

Re: Converting problems

Post by F1CFan1804 on Thu 2 Jul - 12:41

Lee67 wrote:Do you use the "lighting values" in GDB-file for F1C?  Shocked  I don't... Embarassed

I don´t use track-specific lighting values, but a set of standards that José Angel gave in his tutorial that always work.

Oh, I see my mistake, I meant the SCN-file Embarassed

F1CFan1804
Competition racer
Competition racer

Messages : 176
Date d'inscription : 2014-11-15
Localisation : Netherlands

Back to top Go down

Re: Converting problems

Post by F1CFan1804 on Mon 10 Aug - 20:17

I now have something different in the Beijing Formula E track.
It works fine in Test Day, Practice and Warmup, but as soon as I go to the Race, the game is having a CTD.
Does anyone know what's the matter?

F1CFan1804
Competition racer
Competition racer

Messages : 176
Date d'inscription : 2014-11-15
Localisation : Netherlands

Back to top Go down

Re: Converting problems

Post by JALNERVION on Mon 10 Aug - 22:18

F1CFan1804 wrote:I now have something different in the Beijing Formula E track.
It works fine in Test Day, Practice and Warmup, but as soon as I go to the Race, the game is having a CTD.
Does anyone know what's the matter?
ç

Maybe in the race with more cars should be the problem.
avatar
JALNERVION
Competition racer
Competition racer

Messages : 119
Date d'inscription : 2014-11-09

Back to top Go down

Re: Converting problems

Post by JimmyF on Sat 10 Oct - 16:57

F1CFan1804 wrote:as soon as I go to the Race, the game is having a CTD.

Well, perhaps something's missing, like... a crowd texture in the grandstands, that doesn't
load in Practice/Qualify.

Have you checked the trace file, in the LOG folder?

Here's how the path of my F1C's shortcut looks like, in case you don't know how to get
a trace file :s

"C:\Program Files\EA Sports\F1 Challenge 99-02\F1 Challenge 99-02.exe" -trace=1000

Hope that helps.
avatar
JimmyF
Competition racer
Competition racer

Messages : 105
Date d'inscription : 2015-10-10
Age : 50
Localisation : Athens, Greece

Back to top Go down

Re: Converting problems

Post by F1CFan1804 on Wed 25 Nov - 13:22

Hi everybody,

Does anyone know how to fix the lapcount of a track.
I got a newly converted track that doesn't count the laps in a race.

F1CFan1804
Competition racer
Competition racer

Messages : 176
Date d'inscription : 2014-11-15
Localisation : Netherlands

Back to top Go down

Re: Converting problems

Post by JimmyF on Sat 19 Dec - 22:18

F1CFan1804 wrote:Does anyone know how to fix the lap count of a track.

Hi Fan, did you miss me? :b

Listen, I'm not really sure that it can be fixed, but then again I haven't
really ever tried to, so...

Let me start with the basics:
---------------------------

Load up any track in the "AIW+CAMfile Editor", and as you scroll the main
path's WPs with C or X, your eyes should be fixed on the "WP_SCORE" display.

This shows us in which of the three sectors the WP is at.

Here's ISI's explaining, check Albert Park:
wp_score=(2,5146.545) // sector, lap distance

So, from exactly the Start / Finish line (XFINISH.mts) the number is 0
from the first Timeline (XSECTOR1.mts) the number is 1
and from the second Timeline (XSECTOR2.mts) the number is 2

This applies even for the Pitlane's WPs!
If a Pitlane WP is BEFORE the Start / Finish line, it's WP_SCORE number will
start with the number 2.

If a Pitlane WP is AFTER the Start / Finish line, it's WP_SCORE number will
start with the number 0.

               |=====================|

Now, for your problem:
---------------------

Unfortunately, the three timelines are not just numbers, they are real objects
in the 3d world of the track, and so the best way to correct a time lap is to
make sure that these timelines are placed correctly, and then make a new .AIW
in rFactor.

But I suppose one could place them approximately, and by comparing the .AIW
in the "AIW+CAMfile Editor" and what he sees in the 3d track (loaded up in the
"3D SimED Editor"), would try to rectify the WP_SCORE number for each section.

In short, give me a link to the track and I'll take a look.
But it's pretty much guess work, so, don't keep your hopes up high.

JF
avatar
JimmyF
Competition racer
Competition racer

Messages : 105
Date d'inscription : 2015-10-10
Age : 50
Localisation : Athens, Greece

Back to top Go down

Re: Converting problems

Post by Sponsored content


Sponsored content


Back to top Go down

Page 1 of 2 1, 2  Next

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum